Update Chrome or Chrome OS Now

A recent critical security vulnerability (called CVE-2019-5786) has been fixed in the latest version of Google Chrome and Chrome OS. Please do your part and make sure your Chrome is up to date and running version 72.0.3626.121 or higher. Chrome automatically updates but this issue is critical enough to double check to make sure. Instructions are in our knowledge base article here: Updating Google Chrome and Chrome OS


It's important to patch because this vulnerability allows attackers to escape Chrome's security sandbox and perform a "remote code execution" on the underlying operating system, allowing them to run malware/viruses if they wish without your consent. Evidence of this being attempted by hackers on the open internet has been identified by security vendors.